If word + input box in a table cell : Superposition in a table cell

I have a problem with the following code (example) :

|--50%--- |:----25%-----:|:----25%----:|:----30%----:|#+
|Nom : {%input custom.action.nom%}|Prénom :{%input custom.action.nom%}|Date de naissance :{%input custom.action.date as:date%} |

My problem is that when I put an input box in a table cell, in the input view, the input box comes always at the beginning of the cell.
In my case, I wrote something in the cells in front of the input box.
In the input view, the input box is superimposed with the words instead of coming after the words…
So, when you are writing something in the box, it is not possible to read what you are writing…

I don’t know what’s wrong with it.



  1. Headings and inputs in separate rows:
{% stripnewlines %}
|--50%--- |:----25%-----:|:----25%----:#+ {% newline %}
|Nom :|Prénom :|Date de naissance : {% newline %}
|{%input custom.action.nom%}|{%input custom.action.nom%}|{%input custom.action.date as:date%} {% newline %}
{% endstripnewlines %}

  1. Headings & inputs in the same line:
{% stripnewlines %}
|--10%--- |:----22%-----:|--10%--- |:----22%-----:|--15%--- |:----21%-----:#+{% newline %}
|Nom :|{%input custom.action.nom%}|Prénom :|{%input custom.action.nom%}|Date de naissance :|{%input custom.action.date as:date%}{% newline %}
{% endstripnewlines %}

  1. Just inputs with placeholders:
{% stripnewlines %}
|--50%--- |:----25%-----:|:----25%----:#+ {% newline %}
|{%input custom.action.nom placeholder:"Nom" %}|{%input custom.action.prenom placeholder:"Prénom" %}|{%input custom.action.date as:date placeholder:"Date de naissance"%} |{% newline %}
{% endstripnewlines %}

Please let me know if one of the options works for you?

Thanks you for your answer.
But this simple case was to illustrate my problem of superposition.
My real code is far more complex and I need to have text + input box in the same cell :frowning:

Here is my full code :slight_smile:



| Nom | {% case director_type %}{% when 'zaakvoerder' or 'zaakvoerders' %}Parts{% when 'bestuurders' %}Actions{% endcase %} | Voix | Signatures 
|--50%--- |:----10%-----:|:----10%----:|:----30%----:|#+{% for shareholder in period.shareholders  %}{%unless shareholder.amount_of_shares ==0%}
|{{ shareholder.name }} {%if shareholder.custom.type ==1%}, ayant son siège social à {{ shareholder.custom.address_2 }}, {{ shareholder.custom.address_1 }} ({{ shareholder.custom.address_3 }}), <br> représentée par {%input shareholder.custom.rep1 as:text default:'son administrateur délégué'%} : <br> {%input shareholder.custom.rep as:text%} {%if shareholder.custom.rep2 != empty%}et {%endif%}{%input shareholder.custom.rep2 as:text%}{% endif %}| {% =$0+  shareholder.amount_of_shares | integer %} |{% =$1+ shareholder.amount_of_votes | integer %}|<br><br><br><br><br><br>{%input shareholder.custom.signrep as:text default:shareholder.custom.rep%}{%if shareholder.custom.rep2 != empty%}<br><br><br><br><br><br>{%input shareholder.custom.signrep2 as:text default:shareholder.custom.rep2%}{%endif%}|{%endunless%}{% endfor %}
| **Total** | **{{ $0 | integer  }}**| **{{ $1 | integer  }}**|


Easiest solution is to use table with another design - simply delete this symbol in your code : “#”
Please let me know if this works for you.

I have noticed that in your code you are not using “stripnewlines”.
Stripnewlines allows to write code in separate lines, which makes code easier to read. Example:

{% stripnewlines %}
line 1{% newline %} 

line 2{% newline %}

{% endstripnewlines %}


Effectively if I delete the “#”, the problem is solved, but the design of my report is poor…

What is strange, is that before today it worked without problem… We use this code since more than 6 months and the problem appears only today…

Hi @Alexandra,

That’s weird cause I could’ve sworn the table structure with # always has been like that, where an input could not be combined with fixed text within a cell of that table.

I could double check for you, but I don’t think the behaviour is something we would encourage.
How did it look before then, in that one cell? Did the input started right after the fixed text, and how was the alignment with the borders of the cell?

Sorry for back-and-forth though

Hi Sven,

Indeed, I have 3 input boxes in the cell which appear on three lines.
Before today, only the first input box was superposed with the text.
That was annoying but not blocking because there was a default text which had to be modified only in rare cases.
But the second and the third boxes was one below the others at their right place.
In the export view, everything was at the right place.

Now, the 3 input boxes are superposed which mean that it is no more possible to fill it.

We used this template since many months, so I do not understand why the problem appears now…
When I consult client files which were completed previous month, the export document is still ok, but I can’t modify it anymore because of the problem of the 3 input boxes superposed.

Ah okay @Alexandra, I thought the issue only was having one input with some fixed text before/after in one cell. Because that never worked imo…

Having several lines in one cell however, I do not know how that behaved in the table with a #, but we did an update yesterday in the background for bordering cells. I’m guessing it’s related to that.

Sorry for any inconvenience; let me search some more info onto why and what, and I’ll get back to you ASAP.


Please to tell you we are working on a fix. Hate to tell you I cannot give a timing.

Is it an option for you to go with the table structure without the # for now?

So sorry for any inconvenience, but the fix looks promising