Input Box Alignment (without table) && Preview vs. Export Issue


I’m new to Silverfin and have some questions here hopefully someone could help:

  1. I’m trying to align my second input box (the box with placeholder “MM/DD/YYYY”) to the right without the table format, not sure if it is possible. I can’t make it happen right now except for adding a lot of whitespace between the two input boxes;
  2. How to change the font family in the code? I tried different ways but the print out always stay the same;
  3. When I compare preview vs. export, a lot of output are different (e.g. the colored text is gone in export but presented in preview mode, the whitespace is shown as code in export view, etc.) but I assume the two are supposed to be the same?

Here is the comparison (edit mode on top, export in the middle, preview at bottom):

Please see my code here:

    {% input custom.period.quarter as:select options:"March 31,|June 30,|September 30,|December 31," %}

{% capture Company_Name %}
    {% input placeholder:"Company Name" %}
{% endcapture %}

{% stripnewlines %}

To:            {% input placeholder:"Name"  %}    

{% input placeholder:"MM/DD/YYYY" %}


{% newline %}
From: &nbsp;&nbsp;&nbsp;{% input placeholder:"Name" %}


{::font size="l"}<font color='orange'>
Review of testing material for {{ Company_Name }} for the Quarter Ending {{ Qtr }} {{ "now" | date: "%Y" }}


<font face="serif">
This is a test. &nbsp;&nbsp;&nbsp;In addition, information is fake.

{% endstripnewlines %}```

Hi @Mojo

Welcome to the community! Interesting questions, I’m happy to help you with that:

  1. May I ask why you want to avoid the table? You can use whitespaces, but this is not recommended because the html-whitespaces will give different views depending on how big the screen is, landscape / portrait, etc… . If you use the code with table you are 100 % sure the date will always be aligned to the right.
{% newline %}  
| To : 
| {% input %} 
| {% input placeholder:"MM/DD/YYYY" %}
{% newline %}
| From : 
| {% input custom.some.name_sender placeholder:'name' %} 
{% endstripnewlines %}
  1. The font family can only be changed in the styles - advanced settings. Our support team will be happy to assist you with that. I’m afraid that within the template itself, you are not able to toggle different font families.

  2. Here, you should use the code of the font color as follow. You can also see that I uses a capture to define the whitespace. This prevents you need to type in multiple times the same code.

{% stripnewlines %}
{% capture space %}&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;{% endcapture %}


{::font size="l"}<font color="CC0000">
Review of testing material for {{ Company_Name }} for the Quarter Ending {{ Qtr }} {{ "now" | date: "%Y" }}


This is a test.{{ space }} In addition, information is fake.

{% endstripnewlines %}

Can you give this a try? Certainly update us with your findings!

Kind regards,

1 Like

Thanks Sofie. I’ve tried your codes and it works perfectly. Thanks for the help!