Problem font and text in a document


In a disclosure I have the following code with result tags:

{% comment %} CLAUSULE B - ATAD-INTERESTAFTREKBEPERKING {% endcomment %}

{% comment %}Captures{% endcomment %}
{% if custom.ATADinterestlimit.yes_no == 1 and custom.ATAD.option1 == true %}
{% capture ATAD_interestlimit %}{% t “Wij wensen op te merken dat in het kader van de interestaftrekbeperking het geconsolideerde financieringskostensurplus (financieringskosten verminderd met de financieringsopbrengsten) nog slechts aftrekbaar is tot maximum het hoogste van volgende 2 bedragen:”" %}

{% t "-	30% van de geconsolideerde fiscale EBITDA"" %}
{% t "-	3 miljoen EUR."" %}

{% t “Aangezien voor uw dossier het gecumuleerde financieringskosten surplus van de groep effectief kleiner is dan € 3 Mio, valt het dan ook te overwegen om te verzaken aan de EBITDA berekening. Er werd dus eveneens geen verworpen uitgave gerapporteerd.” %}

{% t “Indien wordt verzaakt aan de EBITDA berekening, dient evenwel minstens 1 groepsvennootschap een overeenkomst bij de aangifte vennootschapsbelasting te voegen waarbij alle leden van de groep overeen komen om af te zien van de fiscale EBITDA-berekening.” %}

{% t “De overeenkomst “Vrijstelling van de berekening van de EBITDA” die door elke groepsmaatschappij moet worden ondertekend zal u via afzonderlijk schrijven worden bezorgd.” %}{% endcapture %}

{% if custom.ATAD.vrij_veld == true %}
{% capture ATAD_interestlimit_vrij_veld %}{% t “Aan te vullen voor specifiek dossier: VRIJ AAN TE VULLEN” %}{% endcapture %}
{% endif %}
{% endif %}

{% if custom.ATADinterestlimit.yes_no == 1 and custom.ATAD.option1 == true %}
{{ header_text2 }}
| {{ ATAD_interestlimit }}
| {% if custom.ATAD.vrij_veld == true %}{% input custom.ATAD_interest.vrij_veld as:text default:ATAD_interestlimit_vrij_veld %} {% endif %}

{% endif %}

{% if custom.ATADinterestlimit.yes_no == 1 and custom.ATAD.option1 == true %}
{% result ‘ATAD_interestlimit’ ATAD_interestlimit %}
{% if custom.ATAD_interest.vrij_veld != blank %}
{% result ‘ATAD.vrij_veld’ custom.ATAD_interest.vrij_veld %}
{% else %}
{% result ‘ATAD.vrij_veld’ ATAD_interestlimit_vrij_veld %}
{% endif %}
{% endif %}

The code works perfect in my disclosure. This is the result on the screen:

But I have a problem in my document when I call the result tag for the free text I don’t receive text.

This is the code in my document:

{% if period.reconciliations.2018_working_docs.custom.ATADinterestlimit.yes_no == 1 %}



{{ period.reconciliations.2018_working_docs.results.ATAD_interestlimit }}
{{ period.reconciliations.2018_working_docs.results.ATAD.vrij_veld }}

{% endif %}

This is the result:

You can see that the text “Vrije tekst” is not shown?

My second problem is that the font from the text "- 30% to De overeenkomst … "is not the same as the first paragrah “Wij wensen …” and I don’t know why because whole the text comes from one result tag.

Can you help me please?

Thanks a lot,


Hi Sylvie,

The name of a result cannot contain a dot. Your example:

You can only go one level deep from the results drop, while you are trying two (ATAD end vrij_veld)

Best regards,



It is now working for the section ATAD.

I have now 2 new section and I have the same problem for the text “Free text”.

This is the code:

 {% if custom.thincap.yesno == 1 and custom.thincap.vrij_veld == true %}
  {{ header_text2 }}
  | {{ thin_cap }}
  | {% input custom.thin_cap.vrij_veld as:text default:thin_cap_veld %}
  {% endif %}
  {% if custom.thincap.yesno == 1 %}
    {% result 'thin_cap' thin_cap %}
    {% if custom.thincap.vrij_veld == true %}
          {% result 'thin_cap_vrij_veld' custom.thin_cap.vrij_veld %}
    {% else %}
          {% result 'thin_cap_vrij_veld' thin_cap_veld %}
    {% endif %}
  {% endif %}

{% comment %} CLAUSULE B 2 – THIN CAP REGELING{% endcomment %}
{% if period.reconciliations.2018_working_docs.custom.thincap.yesno == 1 %}

  **<font size="8.5">{% t "CLAUSULE B 2 – THIN CAP REGELING" %}</font>**
  <font size="8.5">{{ period.reconciliations.2018_working_docs.results.thin_cap }}
  <font size="8.5">{{ period.reconciliations.2018_working_docs.results.thin_cap_vrij_veld }}
{% endif %}

Here I don’t use a dot in the result name.

My problem with the font is not solved yet.

Can you have a look please?

Thanks a lot,


Hi @svalais,

I’ve seen that weird behaviour before, and I believe it is related to not using the official font sizes in Silverfin.

Could you try with these font sizes instead?

I’ve checked it with me locally and I could simulate the issue:
Screen Shot 2021-03-23 at 11.21.15

As you can see, the font size you use, doesn’t even respect the text attribute with all the breaks.

{::font size='xl'}{{ period.custom.some.txt }}{:/font}

So I strongly advice to use the official font sizes, which is exactly the reason we made them :relaxed:

Hi Sven,

When I do the export with the defined font, there is no problem with the font size. My text is divided in differents sentence. The first sentence receive the correct font size but the other sentences not:

Can you help me?

Thanks a lot,


Is that screenshot taken from an actual export (so a PDF export) or from the preview mode of a text?

Perhaps it’s also best to share the code behind all that text, if you don’t mind? @svalais

It is a screenshot from an export.

I need more insight on the code generating that export though… Could be an issue if the template also still has the old font sizes. Maybe it’s related to the detail text of the export as well, unless the export is from a text template?

What do you need from me to investigate the issue?

I need to see the code that generates your export @svalais

I’m guessing it’s a text template that gathers all kinds of data from reconciliations? Let’s start with the code from the text template then :relaxed: (or you can check all related templates yourself, by looking for any HTML tags that are used with font size="", cause those cannot be used at all)

It is indeed a text template.

We use .

This works for all the text but not correctly for the text from a result tag. The first paragraph of the result tag is correct and the other paragraph not.

Okay, so let’s debug this then together into several steps :thinking:

Step 1

Create a new text template in a company, and use the exact same result tags but nothing more. So something like:

{{ period.reconciliations.recon_a.results.var_a }}

{{ period.reconciliations.recon_b.results.var_b }}

{{ period.reconciliations.recon_c.results.var_c }}

and print that in a PDF export.
Is the issue still there? Go to step 3
Is the issue not there anymore? Go to step 2

Step 2

The test proved it’s not related to the specific result tags, so that leaves one option only: it is related to other coding in that text template.

For example: if some other text is being coded with <font size="8.5">{{ some_var }}</font> in that same text template, it can already cause the issue you are experiencing.
It’s important to note that the HTML tags (font size) cannot be used anywhere, so if this indeed a text that gathers a lot of other information, you need to be sure nowhere those HTML tag are being used. Not even in a result tag if that result tag holds a capture with that font size being used in it.
Use {::font size="l"}Some text{:/font} instead

So check all related templates, and the use of font sizes

Step 3

So it is related to one of these result tags. Again, we need to debug those results and how they are being made.
Obviously, I don’t have any insight into that, so what you’ll need to do, is investigate the reconciliations where those results are made, and look if those HTML tags are part of the reconciliation (even if they are related to text you don’t use in your text template).

Again, I’ve seen this behaviour before with font sizes not being respected in export and it was related to the use of HTML tags, which we don’t support.
Only these are supported:

Could you give this a try @svalais ? This is extra work I know, but that’s debugging I’m afraid :grimacing:

It cannot be related to detail text of a style either, as that impacts the export of details of account and reconciliation templates only, so that’s already we can cross off our list :muscle:

I did a try with the following code:

{% if period.reconciliations.2018_working_docs.custom.ATADinterestlimit.yes_no == 1 %}

{::font size=“l”}{% t “ATAD-INTERESTAFTREKBEPERKING” %}{:/font}

{::font size=“l”}{{ period.reconciliations.2018_working_docs.results.ATAD_interestlimit }}{:/font}

{::font size=“l”}{{ period.reconciliations.2018_working_docs.results.ATAD_interestlimit1 }}{:/font}

{% endif %}

I also try with the text in your case:

{::font size=“xs”}Tim is a very tiny genius{:/font}
{::font size=“s”}Tim is a tiny genius{:/font}
{::font size=“m”}Tim is a medium genius{:/font}
{::font size=“l”}Tim is a big genius{:/font}
{::font size=“xl”}Tim is a very big genius{:/font}

This is the result in normal view:

There is a problem with my result tags but not with your text.

Then you need to debug how those result tags are made.
Are they part of a reconciliation that also has those HTML tags still?

PS your preview is showing Liquid-tags, meaning something isn’t correct in your code

I don’t get why you are printing those results in a text template between font tags. Can you try without them? So just this:

{% if period.reconciliations.2018_working_docs.custom.ATADinterestlimit.yes_no == 1 %}


{{ period.reconciliations.2018_working_docs.results.ATAD_interestlimit }}

{{ period.reconciliations.2018_working_docs.results.ATAD_interestlimit1 }}

{% endif %}

This way we can be sure it relates to the result tags