Transaction drop usage


Is there any documentation about how to access the information of transactions in a template?
The github page does not contain any information about it, except for the mention of the existence of the drop transaction and the attribute transactions on the account drop.
I couldn’t find any topics on this forum about this either…

Is it possible to reveal the attributes that can be addressed on this drop please?

Thanks in advance.

Hello @robin.bailleul,

To be honest, I have to search for this as well, which means our documentation is not up-to-date (I don’t like to say it, but it is).
As soon I’ve gathered the needed information, I’ll let you know. @Tim has the answer for sure…

Sorry for the delay.

@robin.bailleul, we added an extra documentation page about the transaction drop,

Do you require additional information?

1 Like

Hi @Tim,

Thanks for this.
I already tried using the value, date & relation attributes successfully.

However, I am not able to access the ‘other fields’ of a transaction.
I tried using the columns’ Dutch name, English name and even the data-header value of the html-table.
For example, for accessing the ‘Ref.’ column of the first transaction on the 400000-account, I tried the following code:

  • period.accounts.400000.first.transactions.first.ref
  • period.accounts.400000.first.transactions.first.Ref
  • period.accounts.400000.first.transactions.first[‘ref’]
  • period.accounts.400000.first.transactions.first[‘Ref’]
  • period.accounts.400000.first.transactions.first[‘ref.’]
  • period.accounts.400000.first.transactions.first[‘Ref.’]

None of them seem to work.

Can you maybe give a working example of how to access the other fields correctly?


BR, Robin

Hi @robin.bailleul,

I think there’s still an error in the documentation. ‘.’ are also replaced by ‘_’. Could you try period.accounts.400000.first.transactions.first.Ref_?

1 Like

Hi @Tim,

Thanks for the quick reply.
Replacing the spaces (’ ‘) and points (’.’) by underscores (’_’) in the column names and calling that on the transaction does indeed provide access the transaction attributes :slight_smile: