Result tag with "company variable"

I tried to use a result tag with a company.custom variable, but it seems this does not work, it only worked with a custom or period variable. Is this indeed the case? Is there a workaround?

As an exemple:
I want this in a file:
{% input company.custom.check.1 as:boolean %} - a check that is not depending on a certain period
{% assign check_1 = company.custom.check.1 as:boolean %}
{% result ‘check_1’ check_1 %}

If I then use insights, I like to search for this check_1, but this does not work…

Hi @Warde,

To have a result based on a boolean work correctly in Insights, you’ll need to assign the custom to a variable with a default value.
Please find a detailed explanation here.

Best regards,

Thanks for your answer Simon, but this does not solve the problem.
If I use “company.custom.some.thing”, it does not work, if I use “custom.some.thing”, it works fine.
I do not see how I can solve this.

Hi @Warde

Are you sure, because I tested with your code and it did work.
What exactly happens when you run a report in Insights on this result?
Please share your updated code again.


This is the code I tested Simon:

Check? {% input company.custom.some.thing as:boolean %}
{% assign check = company.custom.some.thing | default:false %}
{% result ‘check’ check %}

I can’t find the “check” variable in SF Insights. If I leave “company” and I only use “custom.some.thing” as a variable, I do find the "check variable in SF Insigts.

So with below code, I can use Insights, with the code above, it does not work.

Check? {% input custom.some.thing as:boolean %}
{% assign check = custom.some.thing | default:false %}
{% result ‘check’ check %}

Hi @Warde

You mean that the result is not appearing in the dropdown, right?
Please try to enter the result name manually in the input field (and then click it when it appears in the dropdown).
Does it work now?


How stupid… tx a lot, it seems this indeed solves the problem. When I use the custom.some.thing, I get all result variables in the dropdown. When I use the company.custom.some.thing, I don’t get a dropdown at all. But when I manually enter the name of the result tag (“check”) in the input field, and then I push the enter button, I can indeed use it. Such strange behaviour, I would never have found this myself. Thanks for the support.



Hi @Warde

Happy to hear that it works now!
Very annoying indeed, but we’ve been promised a major update for Insights functionality by our engineers later this year. Let’s say we’re all looking forward to it! :wink: